ford escort with a zetech engine

I have just had my Mreg escort run with a diagnostic test because it keep chugging and stalling. I was told i needed a throttle position sensor which a new one has now been fitted but i am still getting the same
problem can anyone help? please.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
mandylynn wrote:

The TPS controls the IAC valve, which may be the real problem.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
No one sensor control any single output.
To the original poster.... what led to the replacement of the TPS? An unethical parts store could set a TPS code simply by pressing on the accelerator whilst performing the code scan. If you can have the codes read and post the findings here (the actual codes and not the descriptions). If there are only memory codes and no on demand codes, the KOER test should be run at the same time.

keep
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
What year, how did the problem start?
CJB

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
its a M reg year 93 or 94
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
And the problem started how?
CJB

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.