Ford Focus,runs like crap, then stalls after 30 min help?

Hello, i have a 2001 ford focus se,up intil recently its been ok car.the other day it started chugin and hesitating when i try to excelerate,when i start the car for the first time in the morning its runs fine for 30 min or
so,then begins to act up,until it just stalls its self, and shuts off,if i wait like hour or so, it starts and its fine again,but only for another 30 min.then chugs abit and stalls ive tried replacing fuel filter made no diffrence,still does it.any ideas what it could be?its like somthing gets hot and shuts off crankshafte sensor maybe i dont know little help be great??? the car did same thing like 1year ago for like 1 day and then it cleared up and here i am 1 year later and its not cleraing up lol help please?!!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
They have a lot of problems with the fuel pumps, they even have a extended warranty on those
contact your local dealer for more info if your car is covered

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
There is a lot of these issues on the forums -- seems like the common cause - speedsensor -
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.