Ford Ka 1997

Has anyone else had a problem with the oil light coming on and the engine cutting out for a couple of seconds. This problem is happening intermittently, and yes i have checked the oil and that is fine, there are
no leaks, and the local gargage can find nothing wrong with it so i have got an expensive visit to the main ford dealer. I have heard that this is a common problem on focus's. Any comments?
Rob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I forgot to say it had a new battery put in about 5 days before the problem started......is htis of any relevence?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Not much help but I've never heard of that being a problem on a Focus...
Alex
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
What do you mean the "oil light coming on and the engine cutting out for a couple of seconds"? Can I take it to mean the engine stalls ( stops running ) and you have to restart it ( turn the ignition key to start )?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
No the engine loses power like it is cutting out but it keeps running, the last time it did it i was doing 75 ish down the motorway and it scared the shit out of me i dropped about 10 mph due to the lose of power and then the oil light went off and it was fine again

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I'll assume the light is not actually a oil light but the engine light. Have you checked for codes?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.