ford sapphire

I have a 1990 sapphire with a eec-iv efi system and with new only unleaded petrol available in RSA , my car started to jurk when first riding in morning's ( summer here) or after a long stand "about 3
hours" . checked all connectors I could find cleaned them. after driving for about 5-10 minutes or 4 km car go as per normal no jurking- in a carb model it would seem that the choke is not used or the timing is wrong.
Also about 6 months ago the car started idle uneven going between 800 too 1500 rpm when idling but very intermittend -cleaned the airflow sensor / air bypass sensor, did not help.
and just to mention had the engine overhauled just before christmas.
Any suggestions or where the self test plug is?
anton
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
the self test plug is the black 3 pin connector near to the battery . plug the test eqt' into here and you'll able to get some fault codes
(you are from the UK arnt you?) i'm assusuming this is a sierra sapphire?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
No I am in South africa, everything here when you buy spares it is most of the time " sierra" spares but the odd one is sapphire.just for interesst i have a 2.0 litre OHC (not DOHC)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
anton wrote:

they are designed to allow some air bypass and when they get dirty the IAC opens to wide and cause uneven idle probs and stalling
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.