Ford Taurus--Please read & offer up any advice!!!THANKS

My 1998 Ford Taurus, V6, 80,000 miles, the check engine soon light is on, and when I am in park or stopped at a light for more then 2 minutes the car will die, it always starts right back up, also when
1st starting the car it will idle very high for a few seconds before coming down, The shop already ruled out the O2 sensors, any ideas what else could be causing this???
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Did "the shop" happen to say what code(s) were stored? That is the best place to start. (CEL was/is on) The Idle Air Control valve (IAC) and/or a dirty throttle bore could be it. Clean the throttle bore if it is dirty first. It is a pretty common problem on Fords
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"" wrote:
> > > My 1998 Ford Taurus, V6, 80,000 miles, the check engine soon > light is > > on, and when I am in park or stopped at a light for more > then 2 > > minutes the car will die, it always starts right back up, > also when > > 1st starting the car it will idle very high for a few > seconds before > > coming down, The shop already ruled out the O2 sensors, any > ideas what > > else could be causing this??? > > Did "the shop" happen to say what code(s) were stored? That > is the best > place to start. (CEL was/is on) The Idle Air Control valve > (IAC) and/or a > dirty throttle bore could be it. Clean the throttle bore if it > is dirty > first. It is a pretty common problem on Fords
The shop determined it wasnt the O2 sensors just by me telling them what was going on, I just took it to the shop this morning.. I should hear from them soon. I have never had to take a car to a shop before, so Im afraid they may come up with some crazy problem or price... I was just hoping someone here may have dealt with a similiar problem and could give me a realistic opinion.. Thank you very much for your thoughts... Hopefully the shop doesnt screw me over... Well see...
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.