ford taurus wagon 1996

I have this Ford taurus 1996 wagon, and lately when i start it up a clangy, like pots clanging together, comes form the engine. The noise has gotten louder ove the past days
can anyone help?
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
deep5811 wrote:

request
http://www.autoforumz.com/Ford-Mecury-taurus-wagon-1996-ftopict117501.html
http://www.autoforumz.com/eform.php?pW0081
The heat shield or whatever it's called on the outside of your catalytic converter is probably loose, makes a nice clanging noise on acceleration/deceleration.
Had this happen once to an Escort, and it was nothing two large hose clamps daisy-chained together couldn't quiet down. Probably going on eight years now, they're still there on the original cat.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 26 Apr 2005 21:13:40 -0700, snipped-for-privacy@optonline.net wrote:

bing wrong answer Foctard chek pulleys
hurc ast
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.