FRONT PANEL BLOWING COLD AIR.

I have a 1999 ford expedition.the front heat is blowing cold air, but the rear blows hot..what could be the problem..someone mentioned something about a mode door. where can i find it on my vehicle..

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Just had the very same problem fixed. It appears that the flow control unit had a chip on one of the "doors" thus had to replace the entire unit. Requires removal of the dash. Part cost was ~ $325...can't buy anything but the complete unit.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I don't know about your model - I think you're going to need a look at a service manual to find it. I had a similar problem with the deflection/routing door for the heat plenum in my '87 Aerostar. All of a sudden I wasn't getting anything but defrost. The plastic door had broken during movement in the cold. The point of this post is, when you park your warmed-up vehicle, arrange your heating controls to how you want them when you start the car - for most folks this would be defrost or panel/defrost mix. You don't want to move the controls at all until the car warms up.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.