help my 1996 ford escorts gone loppy

okay yesterday i was driving along when my car suddenly bogs down , i slow down and my car died. well i have no clue whats wrong with it i finally got it home after much physical exertion, but i need my car

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snowhite wrote:

Maybe you are out of gas. You could PUSH it to a gas station or even a mechanic if needed.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
no my cars not out of gas it has half a tank, well i got all that crap fixed , my pcv valve was bad, but its still hesitant during acceleration , but i unhooked my battery to try and reset the idil how long does it take to reste the computer
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snowhite wrote:

You could restart the computer at 3 p.m. this afternoon.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
well theres oil in my air filter, it shudders during accelertaion, i cahnged the pcv valuve fuel filter and air filter breather filter and all that good stuff whats wrong with it now?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snowhite wrote:

If you have oil up in the air cleaner and you tried a new PCV then it may be oil blowing past the piston rings and into the crankcase. You should check the sparkplugs to see if any are oil fouled. New plugs and perhaps a set of wires might do wonders.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

If there was oil in your Air filter, NOw you need to clean the MAF.
To check this, warm the engine. then disconnect the MAF harness (right after the Air Cleaner box) and drive it around the block. If it drives better, your MAF is dirty.
Note all the other sensors must be in good shape. If the engine runs worse, you have another sensor problem, besides.
Remove the sensor assy by using locking pliers on the two screws to loosen, then jewelers Screwdriver.
Use a clean paintbrush or soft bristle toothbrush and rubbing alcohol, do not bump or bend the elements. repeated dip brush, rinse. Takes about 20 minutes total
All this assumes that you dont have serious blowby, in which case, it'll just happen again.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
okay ive repalced the pcv valvue on my car, the fuel filter, spark plugs, and airflter along with the breatehr filter. but it still blos oil, and when u start the car the car idils funny, the check engine light also flashes on and off repeated ly, the timming belt isn't broken, but is there anychance my timimg slipped?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Would you care to share how many million miles that beast has on it? Feel free to use scientific notation. People have noted more things to try. You did some of them. You could find an auto store that would check the failure codes for free. Don't buy stuff based on the codes. Check back here and someone might guide you further with that information. We seem to keep coming back to the blowby. How did the plugs look when you changed them? How does it run while driving with the new plugs? You could also have a vacuum leak in the air intake system. Everything has to be sealed. What happens when you remove the oil filler cap with it running? If you get lots of smoke, oil and pressure out of there, those oil rings are toast.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
okay i diconnected my maf and the car runs better had a diagnostic doen ,said the idle air control valve, and my mass air flow sensor are not working properlyalso my car is misfireing in cylder 4
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If you can get it to run better by changing these parts that's one realistic goal. However, the oil blowing is a separate issue.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.