hesitation and stalling in 2000 taurus

My first problem in this Taurus. This past week of rain and some chill in Florida my 2000 3 liter v-6 either stalls when cold or hesitates while just
starting out in the AM. I hear the belts squeal as the car slows down then it picks back up again. Only a slight sensation of slowing down can be felt. I have not had any problems in the past and once it warms up I have no other problems. The check engine light and service engine soon lamps to not illuminate. I have changed gasoline recently (who hasn't?) Any suggestions on this before it dies on my wife and I catch heck for not fixing it sooner
--
Richard N. Price

snipped-for-privacy@cfl.rr.com
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sometimes if the plug gap gets too big from never being changed the spark will "flashover" from the high tension on the coil or from cracks in the wires when its damp out.
Spray water around the coil and spark plug wires with a spray bottle and you can see and or hear any flashover.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Also to note, 2000 was the first and last year for the coil over plug on the Duratec because of cracking problems. You didn't mention which 3.0 you have however, so if you have a Vulcan or Vulcan Flex-fuel, this wouldn't apply.
CJB
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.