Hesitation during accelleration?

On my 93 Mercury villager, during acceleration the van has a slight hesitation. She'd had a full tune up (plugs, wires, cap, rotor, fuel/air filters, pcv
valve), as well as the timing belt/water pump changed. The hesitation almost seems to occur during shift points. Mostly noticeable around 40 MPH. What type of other things should I start looking at? The transmission fluid level it good, I checked that.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
for starters:
EGR Valve MAF Sensor MAT Sensor Leakage in the intake between the MAF to the throttle body Injectors Weak spark
Do you get the picture?
It's difficult to diagnose over the net, without a more concrete explanation. Please drive the vehicle, try to get a feel of what's happening and post back here.
Refinish King

almost
level
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I've tested the EGR and MAF sensors.. I found a couple of vacum leaks from 11 year old vacum lines, replaced those, and .... filled the tranny. She seems better.
Let's not talk injectors for now .. my Pontiac needs one of those damned things.

pcv
What
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.