Hgh revs

My Ford Focus 1.4 (02 reg) high revs when driving and when stationary sometimes. Does not do all time but when it does if you touch accelerator slightly doesn't help just increases revs even more.
Diagnostic shows nowt, nevertheless changed speed sensor, throttle position sensor and idle control valve and still no joy.
Any ideas please?
Bobby
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Probably an intermittent vacuum leak, follow the tubing from the intake manifold vacuum port while idling. do a gentle tug test of all fittings and connections. ESPECIALLY plastic tee connectors.
Sorry you spent all that money, but hey... someone else will read this and save theirs.
--
Yeh, I'm a Krusty old Geezer, putting up with my 'smartass' is the price
you pay..DEAL with it!
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Well, I checked for vacuum leaks and ended up taking the car into Ford as mobile mechanic could do no more with his primitive diagnostic machine. It was he who changed the TPS, which made little difference.
Ford says:
Carry out full I.D.S. test locate T.P.S. fault, carried out further test, rework T.P.S. and adjust voltage at idle and retest.
...and now everything is tickerty boo! I wish I had gone there in the first place, most probably saving money on parts etc.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.