Moats.... ? for ya

Your a ford guy .... i have a 2003 f250... 4x4 pickup.... all the ford vans and trucks my ather has ever owened always had a squeaky water pump or belt or something....
i think the same thing is "starting" to happen to my f250....
i can only hear the start of it... but does this mean anything serious or is it just a noise?
Kenny Jr.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
After your last post I could say your trying to set me up. So which is it bud, real question or not?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
no i put that crap behind me... others are saying that youre just a direct person... im going to belive that for a bit.. and the question is sincere.... i really dont know why fords do this
Kenny

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Not only Fords have belt noise, all manufactures do.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
is it usually a belt noise or a water pump?? The vans i always head pretty loud... wasnt sure if they were a belt or a water pump...
was wonsering if this was something common with the E series vans??
Thanks, Ken

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Belt noise can be cause by any of the accessories the belt is driving. Water pump, power pump, A/C compressor. Back in the early 90's the 4.9 had a drive belt noise caused by the water pump pulley loosing it's coating. The areas that lost it's coating caused the belt to squeal. Other than that, I do not believe there is any one part that fails like you are suggesting. About the only part that is "common" to belt noise today is the automatic tensenioner, as that over time it looses tension allowing the belt to slip.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
thanks moats.... i got a new question as youll see shortly.. i am just courious what it is... see battery drain after startup
Ken

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.