Mustang In-dash Factory Radio Issue - Pls assist

I have a 02 Mustang and the factory in-dash radio is acting up lately. It has a mind of its own. Sometimes it will work fine and sometime there's no
power. This is an erratic issue. The radio will choose to die and will choose to come back alive at will. Any suggestion???? I'll very much appreciate your thoughts on this.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sounds like a short. A loose wire or connection maybe. First thing I would do is check the wiring harness to be sure that everything is plugged tight. Look for broken or damaged wires.
Another thing you might is try replacing the fuse, it may be one of those that burns ALMOST all the way through but didn't quite make it so it works 'sometimes'
Whatever it turns out to be, let us know what you find out!
Kate
:I have a 02 Mustang and the factory in-dash radio is acting up lately. It : has a mind of its own. Sometimes it will work fine and sometime there's no : power. This is an erratic issue. The radio will choose to die and will : choose to come back alive at will. Any suggestion???? I'll very much : appreciate your thoughts on this. : :
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanx Kate for the info. I will check what you suggested.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.