Need help. Car doesnít start

I have a Mercury Mystique 1996. To make the story short, I tried to start the car this morning and it didnít start. The speedometer and wipers go crazy and the car makes a wierd sound (fast clicking) but it
doesnít start. Any tips on how to fix that?
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
message

Sounds like a dead battery. Did the engine turn over?
Jeff

Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
First thought is low state of charge on the battery, dirty/corroded connections in the starting system... there's not much to go on in your post. I will assume that the motor doesn't turn over and I will assume that everything is fine until your turn the key to "start".
message

http://www.autoforumz.com/Ford-Mecury-help-Car-doesn-start-ftopict105223.html
http://www.autoforumz.com/eform.php?pH9295
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
i have a 1991 ford tempo it is getting fire threw the distributor and sark plugs the car will roll over but it wont start and the batteri goes dead like something is draining the juice out of it, it isent the altinator can you maybe give me some cluse of what it might be? it was running fine then all of the sudden it quit.
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Instead of asking this in this thread, please start another thread. Most people who realize there is a new topic.
Jeff
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
check for a crappy ground
Kenny
message

http://www.autoforumz.com/Ford-Mecury-help-Car-doesn-start-ftopict105223.html
http://www.autoforumz.com/eform.php?pH9295
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.