Need help with transmission

Two days ago, I drove my '90 Ford Escort around 40 miles without any problem.
Yesterday, I saw that automatic transmission in D position drive is not shifting
any gears - it seems that is always in first gear... and I can't exceed 20 miles/hour....
I can also drive in reverse. I do not heard any strange noises except the engine that is running louder because of exceeded RPMs (rot/minutes).
Could be this because of outside cold 5 to 20 Fahrenheit??
Any ideas about what can it be?
How much can cost to fix it?
Thank you,
Chris
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Look for a loose electrical connection, or, vacuum hose somewhere on the transmission. Hope you have not killed the trans. by driving around in that condition..

problem.
shifting any gears - it seems that is always in

engine that is running louder because of

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Yeah. Move to Florida.
Good luck.
Jeff
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hiya Chris,
first check the oil level (car on level ground, engine and 'box up to temperature, handbrake well on or you'll get squashed, run selector thru' all positions three times, put 'box into L or 1, check the oil)
does the 'box have a vacuum sensor? if this is leaking or the pipe has come off you'll get 1st gear and the engine will run like poo.
pottsy.

problem.
shifting any gears - it seems that is always in

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Just to let you know that I found the cause. A joint on top right side on the cable that is going to injector was missing... This joint was already cracked and I think went out because of the road shaking.
As a bad part, because I droved the engine overturned and overheated at high rotations for two miles three times without it, now the head gasket I think went out because my coolant is going into oil....
Chris

problem.
shifting any gears - it seems that is always in

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

the cable that is going to injector was

the road shaking.

high rotations for two miles three times

going into oil....

=======================OMG, this is some kinda joke right? I wont say anymore because, I was taught that - if you dont have anything nice to say.................
--
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com ).
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.