OBD-11 Trouble Codes

i keep coming up with the codes P0401 EGR-insufficent flow. EGR valve has been changed and ports cleaned i also come up with P0171- system adaptive too lean bank 1 i have no clue
what that means. my car did not pass inspection cause of these problems. Anyone have any help for me? I'd appreciate it. thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Car year engine please
And it's OBD II (when in Rome, get it?)
Got to google, this group, search: EGR PFE DPFE
Then search on MAF
Then search the web CLEAN MAF
{But ignore the idgits who say it's real delicate. Just dont bend or drop it. Use clean med bristle paintbrush and rubbing alcohol, clean, rinse, clean rinse several times.}
Then, sign up as a google group user (AOL cant get newsgroups) and be a 'big boy' ;)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The car is a 1996 Windstar and has a 3.8 liter engine
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Great... that request was just for drilll you should always post that info, just in case there's a specific very common occurrence...
However do what I said re the google groups and web searches... based on previous problems solved on here, the problem is probably in your DPFE (refer to autozone locater)
And the 'lean' problem may well be a dirty MAF
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

FYI, Autozone refers to this part as an "EGR pressure sensor".
mike
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
1996 ????????
Does it have the black "plastic" intake or the aluminum 1 ??
If it is the "plastic" 1 replace the intake gaskets (upper and lower) and the bolts with rubber grommets that holds it down, they leak often and cause a lean code.
It also has a problem with the front valve cover, the pcv valve sucks up to much oil causing the intake to get flooded with oil.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.