Oil warning light blinking, 94 Sable 3.8 engine

For the last month or so, my 94 Sable, after it runs for about an hour, the oil warning light blinks when at idle, it does not completely turns on. If I
press the gas pedal just slightly it goes off. Does this mean the oil pump is not working properly? Is this enough to mess up the engine? If I stop the car for 5 minutes it or so, when I start it again the light doesn't blink. It has to be completely warm for it to happen.
Thank you
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Alpha One wrote:

The pump is working fine, it's probably excessive bearing tolerances... the engine is on the way out. How many miles? Last oil change? Dino or Synthetic? Ever have a cooling problem (Head Gaskets...!) resulting in coolant mixed in with the oil? The 3.8 is very prone to trouble...
Rob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Not knowing anything else on your specific situation, I would suspect oil contamination from coolant, resulting in viscosity breakdown...when was the last time you changed your oil? Have you been adding a lot of coolant to the expansion tank of late?

the
I
the
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The next two answer where right on the money I am pretty sure. I removed the oil pan and the bearings were damaged. I also know that when I bought the car used they had just changed the head gasket. It's very likely that antifrezer did mix with the oil. Will replacing the rod bearings fix the problem? Thank you for your answers.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.