OT: small engine trouble

Sorry for posting this here but this group has always been helpful. If you know a better group please tell me and I'll post it there.
I have a 25cc Homelite weedeater that is about a year old with little usage.
It suddenly will not "get up to speed" It will idle perfect, starts very easy, It is just when you try to give it full throttle it boggs down. I have cleaned the spark plug and air filter.(they looked good) I started to adjust the carb but it was running great yesterday and it still idles perfect. Any suggestions as to what is causing this. I even mixed up different gas just to make sure the gas was fresh.
--
Rob



Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

you
usage.
have
adjust
Any
Sounds like it's running lean.... probably got some crud in the high speed needle. Gently close the needle, count the turns so you can open it back to the same setting. Sometimes that will break up the junk so it passes through. If it still won't run right open it a little further. Two stroke engines are pretty touchy about the mixture. If it bogs down and wants to stall it's probably lean, if it keeps running but has no power it's probably rich. Bob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Yes, and FYI. It most likely has 2 mixture screws side by side. One for idle, one for high speed. play with the high speed one....
--
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com ).
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

It was the muffler screen. (spark arrester) It was clogged.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Darn. Should've seen this post sooner. I had a Homelite weedeater do the same thing. Turned out that a mud wasp had built a nest in the muffler. Once he was evicted and the thing was cleaned out, it ran fine. Scott snipped-for-privacy@aol.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.