overheating at idle

Iíve got an overheating problem thatís driving me crazy. It runs hot at an idle and when I raise the RPM the temperature drops. I thought the fan would be the moth likely cause but it seems to be pulling
enough air. So at an idle with the temperature high I took the garden hose and sprayed water a crossed the radiator and the temperature did not drop. I raised the RPM and the temperature dropped. On the road the faster I go the cooler it runs. Any help would be appreciated
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"kennycanic" wrote: > I've got an overheating problem that's driving me crazy. It > runs hot at an idle and when I raise the RPM the temperature > drops. I thought the fan would be the moth likely cause but it > seems to be pulling enough air. So at an idle with the > temperature high I took the garden hose and sprayed water a > crossed the radiator and the temperature did not drop. I > raised the RPM and the temperature dropped. On the road the > faster I go the cooler it runs. Any help would be appreciated
I found the problem! It was the water pump. Iíve ben Working on cars all My life and Iíve Herd about water pump impeller being wore out But this is the first time Iíve ever saw it. Iíll post sume pics later. but thats what the problem was.
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.