pinging 97 Taurus

My 97 Taurus 3.0 Vulcan is pinging under load. No codes, no Check Engine light, idle seems to be slightly rough with the warmer weather. I use good
gas always from the same station.
I did plugs, wires, and all filters about 9 months ago (~8,000 miles), and run mobil1 synthetic & Purolator oil filters.
What should I be looking for?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I would look for loose or disconnected vacuum hoses, although surprised no codes are being thrown.
Chris Bowne Stonington, CT

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Teknical wrote:

Not sure about the 3.0 but when the 4.6 pings it's usually the MAF (mass air flow sensor). Does the 3.0 have injection and a MAF? Easy fix. Involves cleaning.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Use a higher octane.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"Teknical1" wrote: > My 97 Taurus 3.0 Vulcan is pinging under load. No codes, no > Check Engine > light, idle seems to be slightly rough with the warmer > weather. I use good > gas always from the same station. > > I did plugs, wires, and all filters about 9 months ago (~8,000 > miles), and > run mobil1 synthetic & Purolator oil filters. > > > What should I be looking for?
try a professional injection cleaning (motorvac). typically weve seen injector nozzle buildup cause a pinging condition as well as carbon buildup up on valve stems and piston tops. motorvac will do away with both.
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
your egr valve is probably not working. slightly stuck open can cause rough idle and no egr opening under load can cause pinging. that car uses ignition timing and egr to eliminate predetionation. manually open the egr valve with the motor under load and see if the ping stops. the system has a dpfe (egr position) sensor, egr solenoid, and egr valve. if any bad should set a code and check engine light but some times things don't work as they should. that motor is made to run with no additional benifit from any higher that 87 octane. If higher octane apears to fix the problem you probably have deposit buildup on top of the pistons wich a good combustion cleaner (not anything you add to the fuel tank, any good cleaner is not good to set in the fuel system for days)can take car of.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.