Power Steering Noise

We'll here we go again. A few years ago I had the rack & pinion replaced along with all the hoses, but the noise was still there. I never was able to learn what was causing it so I just turned the radio
up and got along. Now when I pull out of the driveway and turn the wheels sharp, it's not turning smooth - just like when the R&P was going bad. This time there's no leaking fluid - level stays the same for weeks.
Any idea on causes for this - and better - what would cure this godawful whining noise?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 3/31/2016 3:22 PM, Snuffy "Hub Cap" McKinney wrote:

If this is the Aerostar again, I suggest you take your cellphone, and a screwdriver then drive out to a deserted field. Put 6 rounds in the engine block with a .357 magnum.... Use the screwdriver to remove the plates, and the cell phone to call 1-877-KARS4KIDS, then call Uber for a ride home....
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Thu, 31 Mar 2016 12:22:04 -0700, "Snuffy \"Hub Cap\" McKinney"

You didn't change the pump when you changed the rack. Wear products from the failed rack also damaged the pump (or possibly it was pump bits that damaged the rack). The rack won't make a noise - the pump definitely will. I'd flush the system well, and then change the pump. The RIGHT thing to do would be to replace the rack,p, and all hoses to be sure everything is in top shape and a bad rack won't take out your new pump.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.