problem with a 2000 ford escort

hi , i have a 2000 ford escort and when i start it up and let it idle it will do it for about 2mins and try to die. it will do that for 2 to 4 mins and then it will die. and if i stop at a stop sign for to long
it will die. oh yes and when it will idle you can smell gas fumes in the car. can anyone help me. does anyone know what is wrong with it
--
Posted at author's request, using http://www.AutoBoardz.com interface
Articles individually verified to usenet standards. Visit URL to contact
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

What engine are we talkin bout here? 2.0L SPI or 2.0L Zetec? I see a TSB for a 2.0L SPI but you need DTC's for this TSB to be accurate. Is your CEL (check engine light) on?
Sound to me like one of two things. Either the IAC isnt allowing enough air into the intake to compensate for the large amount of fuel that is being dumped into your engine during warm up.
Or your injectors are gummed up and stuck partially open and allowing fuel into the intake even when the cylinder isnt on stroke. For this problem add a can of Chevron fuel system cleaner for the next couple of full tanks of gas, and see that will clear it up.
The TSB also points out that you might have faulty exhaust valve seals and the valves are sticking from carbon build up on the seals.
Ford Tech
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.