problems starting my 95 ford escort gt

it started to die my rpm gage stopped working then my radio then my lights then my wipers when i shut it off i wouldn't start again. i replaced the alternator and the battery still wont start and i cant
seem to see the starter not sure where abouts it is??
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sunshine wrote:

First, you might want to see if you can find AmandaG snipped-for-privacy@hotmail.com. She has the exact same problem. Maybe you can work together.
I think you need to find out what is wrong. You could have a problem with one of the battery cables.
Make sure that the battery cables are good. You might have poor connection (make sure both ends of all the cables are clean. Make sure the new battery is charged.
Lesson: Don't start replacing parts until you know what is bad.
Jeff
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Hey thanks for your help guys i took it in and had it looked at and its the switch in the ignition has to be replaced from what i'm told but thanks for that lesson Jeff unfortunatley i had to replace my alternator anyways it was cracked and i had black powder from it all over the place and the belt was cracked and worn. i'm hoping if i switch the ingition switch it will start. I got it to jump start to get it to the garage so i think i have power now because i put a new alternator in it.. again thanks if it doesnt work i'll let everyone know haha have a good may 24 weekend
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.