Sable Transmission Code

I have a 97 Mercury Sable GS with a 3 L engine that has 110K miles on it. It's used mostly for short trips around home, but I occasionally drive it on 200-300 mile trips. Almost every time I do, I get a "Service Engine"
light at about 230-250 miles, but it always goes out after a few days of normal driving at home. I've taken the car to Auto Zone for help with the diagnostics, and the code is P1744, "Manufacturer Controled Transmission Problem". That's strange, because there are no apparant transmission problems. The car shifts smoothly, with no jerks or slipping. The problem has been fairly consistent for 2-3 years and about 15K miles (tells you how much it's driven), and I've had the transmission fluid flushed and changed during that time. I've never been able to get it to a dealer with the light still on for diagnosis/repair because I travel and the light always goes out before I get back home. Does this ring any bells for anyone? I've not been in a hurry to do anything because the light always goes out and nothing seems wrong, but now I'm trying to sell the car and can't do so with a clear conscience as long as this code thing keeps cropping up. Thanks, Mike

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
Add image file
Upload is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.