Squeeky Encore. Any advice before I get ripped off!

Hi,
I have just bought a ten year old escort encore 1.3i 5d. It was low on oil when we got it and started squeeking in the 1st three gears either in
mid to high revs or whenever it was made to work hard. Oil has made a small improvement but the problem always returns after about 50 miles.
I have also noticed that during our first long journey the temperature is almost out of the normal range on the hot side.
Randomly, the backlight for the dails doesn't work any more either along with the right tail light (and its not the bulb) and the left fog light. Spooky!
Thanks in advance if anyone can offer me any advice.
Will.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

the engine, right? not the trans.

probable; Coolant system neglected.. needs flushing, or possible new radiator.

That's wiring.
Dont buy older cars unless you want to learn about car maint and repair.
Get a HAynes book at the least.
--
Yeh, I'm a Krusty old Geezer, putting up with my 'smartass' is the price
you pay..DEAL with it!
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"before I get ripped off"
I think its too late for that

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.