temp. guage going crazy???

hi,does anybody have any ideas on this one,,92 cougar(3.8),the temp guage goes back and forth continously throughout the car running,but the car is not overheating,the car also tends to run rough untill warmed up and even
though car stops stalling and rough ideling after around 5 or so minutes of being warmed up the temp. guage continues to fluxuate wildly,i am guessing a bad temp. sensor that might also have something to do with messing up the cp readings causing the rough idle(iac has been checked and cleaned).any suggestions??? thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
First guess (if you have enough coolant) is the engine thermostat. You might also want to see if bubbles are coming out the overflow when the engine is running. When the head gasket failed in my '93 Cougar, there was enough gas (air) in the system to keep the coolant away from the sensor so it showed cool all the time. No heat from heater, either. It ran fine cold but ran very bad warmed up. Of course, the two symptoms might not be related at all.
If the gauge goes nuts right after a cold start it's likely a wiring problem.
PoD

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Any other gauges going nuts in harmony with the temp ? Then is could be the cluster voltage regulator
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.