Temp guage oscillation ?

My temp gauge oscillates from normal to hot side of normal. Coolant levels look OK. Any ideas??? A new thermostat maybe? Thanks

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Both in the radiator (should be ALL the way full) and in the bottle?

When did this start? Right after service?
--
Yeh, I'm a Krusty old Geezer, putting up with my 'smartass' is the price
you pay..DEAL with it!
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Replace the temp sensor
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Yes, I replaced a rad hose.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Ayup... typical symptom (actually in engine). But since you didnt mention engine year or car... However MOST work out eventually. Thats why i asked if you'd checked the radiator when cold.
One easy thing to try is warm the engine fully then go climb the steepest hill you can find... once the bubble gets in radiator, it's eventually going to go out the bottle.. if the systems working right.
--
Yeh, I'm a Krusty old Geezer, putting up with my 'smartass' is the price
you pay..DEAL with it!
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.