Tempo Fast Idle

I have a '94 Tempo that is idling very fast. On a flat road it pulls the car at 35 mph. When I come to a stop it idles extremely fast for about 5 seconds, then slows down a bit but it is still way too fast. Vacuum hoses
look OK. Can anyone offer any advice? Thanks! Bob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
BobZ wrote:

Replace IAC valve; it's sticking.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I will give it a try...thanks!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I changed out the IAC valve and it fixed the problem. Thanks for the help!! Just FYI in case someone else is going to do this. I bought the replacement at AutoZone. When I went to install it I saw a small piece of paper at the bottom of the box. It said that the replacement MUST be installed in the opposite direction from the original. I did that and it works fine. It did not give any explanation as to why it was necessary. The replacement did seem a bit longer and might have hit the hood if I installed it like the original but I'm not positive. If someone wasn't paying attention I could see how you would just put it on like the old one. Just FYI. Bob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.