TFI module 95 escort 1.9l

All I find on this item is info about the law suit, what I would like to know, would this item going bad result in an engine that dies and won't restart? If there are no other ignition problems, would a defective TFI
module result in no spark. I think it's the item on the distributor, as the only other item is a capacitor.
tonyk
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I do not know the anwser to your question.... it takes about 3 minutes to check for spark... maybe you should try that

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Of course, that's why I asked the question, I have no spark.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

--
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com ).
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I think you have a 1.8. The 1.9 should be distributor-less ( starting date for that is 1991 ). Also the 1.8 does not use a TFI ignition system, it's ignition is called Electronic Spark Advance a very different system.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
tonyk wrote:

received a lawsuit paper on a class action suit that covered just about every ford vehicle that has a TFI on it.. it was a concent decre that ford agreed to pay for the repairs.. being as mine never went bad i think there was an extended warranty fot those that never needed the repair.... call up your local for dealer and ask them to run the vin number of your veh. i their computer to see if they have an extended warranty on it.... if so that will save you pleanty... and yes it gets hot and the engine looses ignition and it will not start..
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I have a 1995 Escort with the 1.9L engine, and I have never heard of this problem or experienced it myself. How about you check out the fourms at http://www.feoa.net (Escort enthusiast site) and see if anyone there has any knowledge of it.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.