(The Return Of) '94 Tbird odometer

(The Return Of) '94 Tbird odometer
Hi,
From previous post (text is after sig), it was determined that the odometer problem *could* be inside the speedo unit (obviously).
A gal on Ebay selling a dashboard cluster related:
I installed this peice in a car to fix the odometer.Everything worked but the odemeter.It was a circuit board under the dash thats was the problem so i put the origional back in and this one was left over.Any more questions I will be happy to answer thanks for looking nah no cb a mechanic replaced so kind of odometer control box or curcuit board for me well it fixed it said it was under the dash but not in the instrument cluster thats all i know
So, does anyone know anything about an instrument cluster control board (or somesuch) in a '94 'Boid LX V8? I shined a light under the dash this morn, couldn't see much of anything 'cept the fuseboxes, steering, etc.
TIA, Puddin'
'allo,
I log date, mileage, and gallons when I gas up so as to monitor gas-mileage. Did so yesterday and noticed that the mileage was the same as the last gas-fill.
Reset the tripmeter and put 25 mi. on the beasty. No change in odometer or tripmeter readings.
But the speedo appears to work fine.
Anybody wrestled such an alligator or just have knowledge of how speedo/odometer/tripmeter function on '94 'Boid (LX V8, 65k mi.)? The '94 is the one with the nice set of analog gauges.
Thanks, Puddin'
Pease pudding hot, Pease pudding cold, Pease pudding in the pot Nine days old.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I have same problem on '93 Crown Vic w/4.6L engine. Filled up gas, reset odometer and it stopped working, speedo OK. Ford CD diags says if speedo is OK , here's the bad part, 'replace the speedometer' unit. UGH ! Looks like a long process. BTW, Ford CD diags says: if speedo and odometer don't work , check/replace the speed sensor on side of tranny. I haven't decided if I want to tear into that yet... JRnNC
Puddin' Man wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
See thread "'94 Tbird odometer" 8-4-06. Lugnut had similar problem, replaced cluster with unit from Ebay. Maybe $40-$50 total cost exclusive of your labor.
Skoal, P

Pease pudding hot, Pease pudding cold, Pease pudding in the pot Nine days old.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.