Transmission "jerking" on '95 Escort

I've got a 95 with 98K on it. When shifting from first to second, there's a noticeable "jerk" that occurs, but ONLY when the car is cold (i.e. for the
first 5-7 minutes of operation).
Of course, I'm in Cleveland, and it's getting colder.
Any advice?
Bill
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Have you done any transmission maintenance on this vehicle?
CJB

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Sounds like it's time for a fluid and filter change...
-LMB
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I think he has a manual transmission, probably the clutch.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
No maintenance yet. Took the car to a local repair shop. Their story was that the trannie is fried, and would need to be replaced. Although they've been reliable in the past, I question this diagnosis since it behaves just fine after warmup.
Planned to change fluid and filter over the weekend, though. BTW, it IS an automatic. Thinking of putting one of the "transmission flush" products through it before the change. If anyone has any experience with these fluids, I'd appreciate the feedback.
Bill

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Don't expect miracles with the tranny flush chemicals...they CAN help to some extent (Trans-X worked fairly well for my C4, )
-LMB
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.