windstar ping

I've got a 99 windstar with just over 100,000 miles, for some time now its made a noise at certain driving conditions that i always thought was a rattling heat shield but my dad said it sounded like an octane ping.
I'm pretty sure its an octane ping now because i recently got back from some very hilly driving in upstate NY where it tested it out. 87 octane, A/C on, going up hill, rattle/pinged like crazy, 89 octance not a sound, or at least to faint for me to pick up.
Any idea what might cause it since ford calls for the 87? heres the list of what I've done since buying the van thats fuel/air/ignition related.
date miles
fuel filter 5/28/2003 70350 clean IAC 11/2/2003 76350 clean throttle body 11/2/2003 76350 plugs and wires 2/4/2004 78103 air filter 9/10/2004 83600 clean MAF fuel filter 12/21/2004 84800 TSB 03-16-1 4/14/2005 87962 < thats the one that keeps oil out of the intake manifold.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
petebert wrote:

I've seen a dirty MAF due that. I would clean that sucker again at least. Its got about 20K on the plugs too right? If they weren't double platinum I'd do those too. Oh, and a fuel filter just because they are cheap. I have also seen "octane plugs" I think its called. Its a connector under the hood (looks exactly like a spout connector) that you yank out that helps with ping. I guess it retards the timing just a little. You'll have to do your own research on that one though, I don't know that much about it, or even if your van has one. :)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.