’00 zx3 manual : Hard Shift in every gear + amber ck eng Lgt

2000zx3: manual trans problem: hard shift every gear: It delays for a sec then jerks into gear... if I ride the clutch it will go into gear smoothly...:: had fuel inj cleaned , oil changed and new air
filter. Now the amber engine light is on also... I disc pos battery for 15 min... it still did not reset the ck eng lgt: Has 80k miles: No problems before work done... Plus ... anyone know where the hook up is for the computer code reader???
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
✖
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"ivydragonn" wrote: > 2000zx3: manual trans problem: hard shift every gear: It > delays for a sec then jerks into gear... if I ride the clutch > it will go into gear smoothly...:: had fuel inj cleaned , oil > changed and new air filter. Now the amber engine light is on > also... I disc pos battery for 15 min... it still did not > reset the ck eng lgt: Has 80k miles: No problems before work > done... > > Plus ... anyone know where the hook up is for the computer > code reader???
N/M … One of the sensors was left disconnected… alls well now…
Add pictures here
✖
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.