2001 Focus emission system question

As I was driving today, My Focus started hesitating slightly at low RMPs. The RPMs were just high enough to maintain my speed. The hesitation seems to be at
speeds around 45 MPH and below. At least I didn't notice it at highway speeds.
A little later in the day, the emission system warning light came on. I am thinking it might be the oxygen sensor, but I haven't had a chance to really look into it, since it was the weekend and late in the evening.
Anyone have any experience with this before> Thanks in advance.
John
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I had a similar experience in a different make and model car, and the symptoms you describe sound the same; in my case, it was the oxygen sensors that needed to be replaced. However, it could be a number of things (a misfire, cam shaft position sensor, etc.), so you should probably have someone pull the code for you. Also, if it is the O2 sensor and you drive for too long (several weeks) without fixing it, it could damage your catalytic converter.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
That's what it appears to be the DPFE Sensor. About $70 in Houston. I did not know that it was a warrenty item to 80K. I changed it out myself because I %0K on my 2001. It appears to be a recurring problem, so I will keep it in mind.
LMA

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.