2003 Focus stalls intermittently with warm engine

My 2003 Focus wagon behaves stupidly sometimes. Here is what it does: I might drive it a bit and then stop somewhere to go to the store or something, and then when I come out and try to start her, she stalls
immedieately, and then only when I hit the gas will she stay started, then when I drive her and approach a red light and slow down and downshift (it's a manual trans) push in the clutch and approach a full stop, she stalls again. So it'll stall upon slowing down for a red light or stop sign each time during the duration of the trip. This stupid behavior never occurs in the morning when I go to work, or in the afternoon when I leave work, only after I park her for a moment to run an errand. And this behavior doesn't always occur. It's like maybe every two months it behavoes stupidly like this. Otherwise, she runs ok, as expected. ANy ideas? Mechanic says the engine checks out fine. I have been reading about fuel line issues....any ideas?
Thanks in Advance
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I guess the faulty throttle sensor. Try a new one then see what happens.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.