2003 Focus ZTS - Brake light failure

I have a 2003 Ford Focus ZTS. The third break light is working fine but the other two are not. I have checked the fuses, everything seems fine. I assume the brake switch is working fine because of the 3rd
brake light working correctly. Tail lights light up with the headlights on and turn signal and hazards works. I noticed hazards use a different bulb, though. I had changed one of the break light bulbs a year ago.
Any suggestions on what else to check?
Thanks!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
1) Yes, make sure the stop light bulbs are good. Someone complained about the exact same problem a while back. It turned out that both bulbs were bad!
2) There have been a few reports of the wiring harness becoming damaged where it enters the hatch.
3) The center stop light goes directly to the stop light switch. The two side stop lights are routed through the "Lighting Control Module" (LCM). If (1) and (2) check OK, I would suspect the LCM.
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for the reply. I found the message you were referring to yesterday and although I looked at the light bulbs and they looked fine, I had an extra new bulb in the trunk and tried it. It worked! Go figure. What are the odds that both bulbs go out at the same time!??
I then purchased another bulb for the other side and it is now working correctly. We've had a lot of rain recently and maybe this was a factor.
On Wed, 11 Jul 2007 23:17:25 -0500, Peter Piper

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Matt Scoff wrote:

Unless you check them daily, how do you know when the first one failed?
Chris
--
Remove prejudice to reply.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I check them often. I don't want to get a ticket. Reflections off of office building windows work best. Not to mention I changed one bulb a year ago, which also makes the timing odd since one bulb is about 3 years newer than the other.
Anyways, that doesn't really matter.
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.