Burning Smell

I have a 2000 Focus wagon, with automatic transmission. The car has an odor that I can not find the source of. It smells somewhat like burning brakes, but this is not the source of the problem. I thought perhaps
brake fluid or transmission fluid leaking onto the exhaust system, but I don't see smoke nor do i see a drop in fluids. Anyone have similar problems or ideas? thanks
mike
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I'd suspect an oil leak around the exhaust manifold. It could be as simple as a valve cover gasket. You might get an engine shampoo (available at many car washes) then you could check for leaks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I had the same problem, started christmas eve , horrible smell and what seemed to be a puncture, when I checked tyres nothing, problem seemed to be when accelerating from about 30 mph, got it seen to by local ford garage eventually when they reopened, turned out to be a problem with the ignition coil,
-- M.See
--
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com ).
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.