Busted horn

When I hit the horn on my Focus all I hear is a clicking sound coming from the vicinity of the glove box. Is the horn itself blown or is it just a blown fuse/relay? Anyone have any ideas? Is it a DIY fix or something best
left to someone who knows what they are doing?
Gary
--
Self-referencing
Five, seven, five syllables
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Gary,
That the relay works means that the fuse, switch and wiring are all ok. I would pull the horn wire and check it with a meter to see if it has 12V when someone presses the horn switch. If it doesn't, the relay or connections from it may be bad. If it has 12V at the horn, you simply need a new horn (most likely). It is located near the front, under the bumper area - driver's side, I think. Easy to remove.
If you can't find it, I will look at whree mine is - '01 ZX3.
Gary
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

And from another Gary.... this happened to mine last year. They replaced the horn and it still didn't work. They said it ended up being a corroded connector block. I presume the one that connects the horn to the electrical system. I never actually looked at this myself.
G.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.