Central locking with a mind of its own

I've got a weird problem with our 1999 Focus Zetec. When the weather is cold we can unlock the car using the remote and just the driver's door unlocks (correctly). But then after a short delay (anything from
a few seconds to a few minutes) the rest of the car unlocks. This is really weird when you are driving along and the car decides to unlock everything. While the car interior warms up you can hear the central locking motors trying to unlock the car again. Occasionally the central locking even locks all the doors. Fortunately the car has never unlocked itself having been locked up and left but I'm worried that it is only a matter of time before this happens.
I've seen someone with a similar problem to this on the group but no solution. Anyone have an answer (the dealer, needless to say, is useless)?
Thanks
Iain
PS Please post responses to the newsgroup not email.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Firstly try the car for afew days with the remote key in the house and use the spare! its not unheard of the buttons to wear in these and start making contact even when not pressed.
If no difference access the CDL computer in the drivers footwell behind the kickpanel and strapped to the front of the engine ecu. Disconnect the battery first (note radio code) then remove the connectors and check for corrosion, damp, poor connections and remedy as necessary. Some aerosol brake or contact / switch cleaner and an old toothbrush used carefully with clean up the terminals on both the multiplug and the pins of the CDL unit. It will be difficult to tell but if any terminals aren't making agood grip on their companions, squeeze them up alittle carefully.
If you feel capable, open up the CDL unit and check the circuit board for damp ingress and dry joints which are closing up when the unit gets warm. Remedy as necessary.
Reconnect the battery and try that. If you still have problems then the CDL unit is most likely at fault.
Tim..
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

On my North American 2000 wagon I had the dealer reprogram the security module to make this function purely manual. I didn't have a problem, merely didn't like the automatic locking. Perhaps you could have the same thing done.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.