Emissions test problems

I just bought a 2006 ZX3 se the other day and I went to get the car inspected for emissions. The technician told me that he kept getting "No Data" feedback and told me to go to the Ford dealership. A friend of
a friend of mine is a mechanic for a Ford dealership and he told my friend that it is an ongoing problem with some of their cars. He said it also occurs with some Dodge cars. He says it is probably a software glitch with the state emissions test that wipes out the data when the machine is hooked up to the car.
Any comments?
creo
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

How typical of the Ford dealer to say "its an ongoing problem" only after you bought the car.
What happens if you can't pass the emissions test?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I took the car to the dealership to have the emissions test taken again. It took over an hour to get my car back but they said "they had no problem" If I was unable to pass the emissions test I would have had to go to the Department of Motor Vehicles (DMV) and fill out a form to waive the test for that year. The DMV is aware of the issue also.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.