Engine Rattle on 2.0 L Focus (UK)

Hi, I've just bought a 2.0 litre Zetec Estate, petrol, manual, 2 years old and 32k. It's still has 12 months warranty so I got a few niggles sorted out at
my local dealer. One "problem" is an engine rattle at idle, which disappeared when I pressed the clutch in. To me this could be a sympton of a worn clutch release bearing. The dealer says that it's normal and the result of a redesigned gearbox with more play in the idler system, as the tighter cogs on the old design wore out quicker! Does anyone else get this noise or is it BS from the dealer?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I owned a 2003 SVT that developed the same problem. The dealer told me that it was the flywheel. They changed the flywheel twice and the problem was still there. The dealer called the Ford Rep and they decided that they were going to give me a new car. I had 18,000 miles on the 2003 and eneded up with a 2004 SVT with 43 miles. They wanted me to pay the $800.00 difference however they ended up waiving the price difference and I had no out of pocket expense for the new car. Kudos to Ford and Hoffman Ford of East Hartford CT for standing behind their customers. Don't let the dealer BS you. My new car has no rattle at all and I experiencing the same exact problems that you have with my 2003. GOOD LUCK!!!!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

BS from dealer! Its either the clutch release bearing as you say or worse, the dual mass flywheel parting company with itself. *Insist* the dealer splits the bell housing and inspects the innards.
Tim..
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.