ENGINE WARNING LIGHT ON FORD FOCUS 1.6LX/2001

Can someone help me I had my yellow engine warning light come on today and the engine was running with a stuttery sort of action. When I went over 45 mph the yellow light would start flashing so I did as manual
said and reduce speed and once I got to about 10mph the light stopped flashing but remained illuminated. My engine temperature was normal.
Does anyone have any ideas to help me solve this?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
SEDGIE wrote:

do as the manual says and take it to a dealer / independant with diagnostic tools
--


Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Certain faults produce erroneous error codes. When my (ignition) coil pack failed the error codes recorded were nothing to do with the fault. It was possibly due to interference from the faulty high voltage circuits getting back into the engine management system and generating false code.
--
Alan
news2006 amac f2s com
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

First guess is that the coil pack has failed. I had similar problems on a UK 1.6 2001 model and it appears it is a common fault on this age of car. In my case it felt like the car was only running on two or three cylinders.
Search the news archives at <http://groups.google.com/ (this is different to the Google search engine)
Search for focus coil pack
If it is the coil, and you do replace it yourself, also change the plugs and check the ignition leads.
--
Alan
news2006 amac f2s com
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.