faulty fuel gauge

Hello Focus Owners, First thing finally went wrong on my '01 wagon 1.6 liter after 2.5 years....a faulty fuel gauge..Low fuel light came on the other day..I
filled it up but it only took 45 liters at max. (the tank holds 55 liters according to manual). Yesterday, low fuel light came on again (after driving 30 kms) and the gauge started to register below E. Restarted again but nothing changed..The light is on and it reads 0. What do you thing the problem might be? the gauge itself or a sensor in the tank or a faulty wire? How difficult to diagnose and how much to fix it? I appericate your input on this.. Thanx in advance
Ahmet
'01 wagon 1.6 liter, 18,000 kms Turkey
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Common fault with Foci around the world. Only cure is replacement, which involves the pump as well since they come as a unit.
Apparently another common problem is ignition switches. I've had both failures on my 2000 wagon, but I still love my Focus (I keep drooling over any ZTW that passes by).
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

You and me both. I want a 5-speed.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Glad to read the fix for this. I have a 2000 Focus and the gauge has worked off and on since I got it. The dealer tells me it works fine when they have it and they have no idea what it could be. The temperature gauge only works sometimes and the r.f. door lock doesn't work 100% of the time. I like drivin' the little guy but I'm going back to Toyotas. jor

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.