Focus electrical problem solved

I just thought I'd post the solution to my problem here in case anyone else has probs with their electrics.
What the problem was with my fuses blowing and lights on the dash and
instruments failing was due to a short in a wire behind the radio. There is a piece of metal behind there with a sharp edge on it and the wire loom was resting on it and so every time i went over a bump in the road etc it would rub against the sharp edge of this piece of metal eventually cutting through the wires. (poor design on Fords part I'd say)
Anyway my problem is solved now, good luck with yours.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks, What year and model Focus? Gary

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sorry for forgetting that valuable piece of info. It is a 2001 focus 1.8 diesel estate.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yes, My son had a 2001. They had other design flaws on the Z3. If the rear bumper was ever hit, no matter if it was not hard it had a tendancy to split the outer covering on a very sharp edge of the internal steel bumper.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.