Focus TDCI 2003 dashboard indicators ramdom failure

Few days ago a problem appeared on my Focus
Both motor and car speed indicators drop to zero, LCD mileage indicator shows dash lines (------) instead of kilometers and a second after the
orange motor pilot lamp lit. Then a few seconds or minutes later indicators kick back to normal and the problem disappears.
I don't feel any influence on engine behaviour and the failure seems absolutely random not depending on engine or car speed or any electrical device switching.
Sometimes other pilot lamps lit (e.g. battery).
Ford Service made already a computer check while the problem was not present (no luck) and ddn't find any fault. The only logged alarm was "positive of fuel indicator level sensor shorted to ground" but the fuel indicator is the only which never drops during the failure.
Has anybody as an idea about this strange problem?
Gian Piero
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Oh my gosh! That is the exact problem I am having with my 2000 SE. My boss' son is Ford Certified. Right off the bat he knew what the problem/solution was. He stated that the Instrument Cluster needs to be replaced. Your car sounds young enought to still be under warranty. Good luck!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.