ford focus 2001

we washed the motor and under the motor and now my car is all shaky he changed the spark plugs and the cables but the check engine is on and it still shakes when were at a stop whats going on?????

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I had the same thing happen. I have a zx3 with a zetec motor, the problem is water uner the cover. Warm up the engine, turn it off, pull the pluge wires, try to remove all the water in the plug chamber, let it dry out over night, That should be it, if not repeat process. Mike

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Water in plug chamber under cover. Let it dry out, by removing wires when engine is warm, sop up water with paper towel and let dry wit wire out, replace wires and should work. Mine did. Mike

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
How do you remove the plug wires from the plugs? Mine are firmly stuck on.
Mike Eppler wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

It takes some force to to pull the wires off the plugs. Also check the center wire going into your coil pack, they are known to wear thin.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.