heater blower only works on high setting

I am aware of other post about the blower only working on high,but none of the links work. I want to fix it myself,I think it is the thermal fuse. Can someone please give me some working links or a description of what I
need to take out to get to it? I have a 2003 focus zts. Any help would be appreciated. I can't use the a/c because it only works on the lower fan settings and it has been in the 90s lately.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
In message

Answered a few days ago in this group - the news archive has a copy at:
<http://groups-beta.google.com/group/alt.autos.ford.focus/browse_thread/t hread/d3f8f824445fd5c0/ef3fd85dc25d2ecb?q=Re:+internal+blower%2Ffan+dont+ work&rnum=1&hl=en#ef3fd85dc25d2ecb>
Circuit/thermal fuse details at <http://www.amacleod.clara.co.u k/focus/>
--
Alan
mailto:news2me_a snipped-for-privacy@amacleod.clara.co.uk
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Dude, the reason the fan only works on high is because the resistor is bad. Call the ford dealer, get the part -- like $10. It mounts under the dash on the firewall on the passenger side. You won't likely find it by looking at the system wiring -- just know that it is a flat plastic piece, mounted by a screw or two I believe, with the plug into it. Best bet, buy the replacement first so you can recognize what it looks like. Screwdriver, flashlight, $10, and like 10 minutes tops and you're golden.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.