Possible Alternator Problem

Recently, the spedometer as well as the gas and oil meters on the dash have been going from their normal resting pointing and shooting all the way to the
far right when I start my car. It does not do this every time I start my car, but has been doing it many times a week. This once happened when I had an Oldsmobile, and I ended up needing my alternator replaced. Could this be an early warning sign even though nothing else seems to be wrong driving wise?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

There is a dash test mode that is obtained by holding the odometer reset in while starting the car.
http://www.mustangworld.com/ourpics/fcar/dtcodes.htm
Perhaps the odometer reset switch is not fully disengaged?
--
Alan
news2006 amac f2s com
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Alan wrote:

I thought that was part of normal power-on self test, AFAIK mine has been doing that since I got it in '01, it pegs at the top, drops back to the bottom then goes to normal operation from then on.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
me wrote:
[...]

No, it's not normal.
I've had my '99 LX from new and it only started doing it about a year ago. At first it was only when the weather was really cold. Now it happens most of the time, but not when the car has had a good run, and is then restarted.
I've assumed it is related to the battery voltage as I still have the original but that's just a guess. It doesn't seem to be a problem so I'm just ignoring it :-)
Chris
--
Remove prejudice to reply

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Chris Whelan wrote:

I might be battery then, I know mine is getting weak, they tested it last time it was in for an oil change, I did the brakes then instead, decided to wait another month for the battery, until it gets a little colder.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.