Speedo / Milage display fault

Hi. Wife's Focus , 5 years old. Had developed a fault... Speedo drops to Nil ( MPH ) and digi mileage counter cuts out. Both intermittently. Any ideas ?
Cheers Jeff
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Does engine loose power, or stall if you depress the clutch at the same time?
If so, its the VSS or its connector, located on the diff casing directly below the inlet manifold.
Very common fault.
Tim..
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
No . Any other ideas ? Best regards Jeff

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Actualy the wife says the car is spluttering a bit at times ? Would this be the same fault i wonder ? Cheers again Jeff

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Yes, more than likely.
Tim..
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I just went though a similar experience with my 2002 Focus SE.
It was a bad vehicle speed sensor.
The only time it noticably impacted the motor was once when I was in stop and go traffic I had it stall on me. Otherwise the car ran fine.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.