Zetec cam belt failure

Cam belt tensioner failed on Ford Zetec engine and has bent the 16 valves. There are dents in the pistons but the bores have not been damaged and the pistons float indicating the top ring is not jammed.
Plan to fit a scond hand head but wonder about the consequence of any damage to the pistons. Has anybody any experience of recovering a ford from this sort of failure?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
how many miles?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

1.6 / 1.8 or 2.0 ?
If its either of the latter, then you are VERY VERY unfortunate. Belt failure (either belt itself or via failed tensioner rollers) on the E enignes is almost totally unheard of.
Tim..
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Not really that is unheard of, official ford mechanics alerted me that would be wise to change the belt and tensioner at 100.000 km instead 150.000km because of potenitial failure...
Engine Zetec se 1.4
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Possibly related to this post so apologies if it's not!
I've read with some concern over reports of tensioner failures. My four year old UK 2.0 Ghia has covered 58K. The engine has a squeak first thing in the morning when the engine is stone cold. Only occurs in the winter months i.e. no sound during the summer but it's recently started again as th weather has cooled down. I'm wondering if this is the Tensioner? If it is, should I be worried? I've not great desire for an engine rebuild if I can avoid it.
Pete
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

could be your water pump
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You Rang? wrote:

My Volvo had a squeaky tensioner. Idiot dealer said it was the power steering pump so I ignored it but when it was replaced with the timing belt, it was the tensioner making the noise. I was lucky - Be careful!!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.